All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: md3 export problems
PostPosted: Sun Oct 10, 2010 8:30 pm 
Offline
Master
Master
User avatar

Joined: Fri Jun 12, 2009 4:01 pm
Posts: 459
So, I have a model, 850 vertices, ~1600 faces. The problem is, after converting it to md3, the exporter auto smoothes the faces causing two issues.

The first one is, this doubles the vertex count (vertices get automatically separated) and ET doesn't want to work with a model that has more than 1025 vertices per segment.
The second problem is, a great portion of the model is supposed to have hard edges and this makes the shading look blurred.

Since the limitation isn't per model, I can split it up into more segments which are under 1025v limit. The thing is, that doesn't really make sense since I don't want to use smooth shading at all.

I've tried exporting with blender, making sure that all faces were "set solid" (as opposed to set smooth).
Also with Misfit Model 3D, I start up with a 850V model and as soon as it's saved as .md3, the vertice count jumps to 1700, even though it's smoothing setting is set to 0.
Lastly, in Milkshape, smoothing groups aren't used and auto smooth is off, the problem remains.

When the model is exported to .ase or .obj, there are no problems. Is this the feature of .md3? Auto smoothed faces?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2010 3:17 am 
Offline
Expert
Expert

Joined: Mon Jul 06, 2009 11:22 pm
Posts: 157
Just break your model up into more pieces. Done.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2010 8:02 pm 
Offline
Expert
Expert
User avatar

Joined: Thu Jul 09, 2009 8:28 pm
Posts: 204
Location: Canada
I've never had problems with smothing in MD3, so I dunno what is the problem.

_________________
Image
"Statistics is the study of how Greek letters can over-complicate graphs."


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 11, 2010 11:02 pm 
Offline
Expert
Expert

Joined: Mon Jul 06, 2009 11:22 pm
Posts: 157
You need to remember something, the .md3 exporter recalculates the normals of your models, doubling the verts. The only way around it is to break up your model into lots of small pieces.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Style created by © Matti, gry komputerowe, reklama sem reklama seo

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group