Comments: firefights causing client lock ups (Esp. in linux)
Page 1 of 3

Author:  RealCorran [ Sat Sep 30, 2006 7:58 pm ]
Post subject:  Comments: firefights causing client lock ups (Esp. in linux)

When someone starts firing, sometimes the client locks up (about 25-30% of the time). Others see me go to 999 and only when the firing stops to I return to control. This _ONLY_ happens when others fire, not myself. It also doesn't happen when nobody is firing.

This has been seen by many people on many distros, but I will post most of my config details to see if we can isolate the cause a bit, as this makes the game 99.9% unplayable for me.

Debian unstable with vanilla kernel (config located here.)
Intel P4 on 850 chipset.
nVidia Corporation NV20 [GeForce3] (rev a3) (and nvidia kernel module)
Creative Labs SB Live! EMU10k1 (rev 07)

It seems to be more likely on populated servers, but I have gotten in playing 1v1. It seems to depend on weapon (ak47 is much more likly to cause it than a mac 10)

Author:  Rad [ Sat Sep 30, 2006 8:39 pm ]
Post subject: 

It happens to me as well. My specs:

Debian 3.1 rc 5
Intel Pentium 4 on 850 chipset.
nVidia GeForce something (i don't want to check it now :), but it has 64 mb).
Creative SB Live 5.1.

I don't think the problem is in the video, as it works quite well when there is no fire, but in the sound.

In the previous tc:e (0.48 ) i had this bug, and i fixed it by turning down the sound to 22 Khz. In this version this is not possible, as there are only 44 Khz sounds. If it isn't possible to find the bug, please, please, consider including 22 Khz sounds in next release (please!).

Btw, some more info: things i've heard about this bug (may not be important, or even true).
-It only applies to Intel users.
-Some people said it's related with the number of pk3 the server has (i don't think so, i think it's a client issue).
-Coroner thought it was related with the layer penetration code (i don't know if he finally found out if that was true or not).
-It's also called "firelag bug".

This is the most annoying thing by far to me from this release. If devs need help on finding what causes this, i offer myself to make all the tests they want.

Let's hope we find where the bug is.

Author:  nicke [ Sat Sep 30, 2006 9:21 pm ]
Post subject: 

I can confirm this bug too, it occures during firefights, with stuttering sound. It can be observed while in spectating mode on a random server while browsing into a firefight.

My specs:
Ubuntu 6.06.1 LTS dapper
Intel(R) Pentium(R) 4 CPU 3.00GHz
MemTotal: 1034520 kB
Graphics card: GeForce FX 5900 Ultra
Soundcard: Soundblaster Audigy

Author:  luminoso [ Sat Sep 30, 2006 10:56 pm ]
Post subject: 

Hi.. I have same problem.
First, I collected some computer specs from our small TC:E portuguese comunity that had same problem:

1)2.6.17-9-386, intel pentium 4 3.2ghz ceder mill, 1gb ram, nvidia geforce 7900gt, Intel Corporation 82801G (ICH7 Family) AC'97 Audio Controller

2)Linux main 2.6.16-gentoo-r9 #3 SMP PREEMPT Sun Jul 2 19:48:45 GMT 2006 i686 Intel(R) Pentium(R) 4 CPU 2.66GHz GenuineIntel GNU/Linux,512MB ram, 20GB partition in reiserfs, Nvidia GeForce 4 mx 440, gentoo i686

3)Intel celeron 2ghz, 768mb ram, msi motherboard something, audigy 2 zs, nv 6600gt

And my self:

4)os[Linux 2.6.18-ck1 i686] distro[Gentoo Linux "~x86"] cpu[2 x Intel(R) Pentium(R) 4 CPU 2.80GHz (GenuineIntel) @ 3.21GHz] mem[Physical : 2.0GB, 61.8% free] disk[Total : 213.94GB, 50.40% Free] video[nVidia Corporation NV31 [GeForce FX 5600]] sound[EMU10K1 - SBLive! Value [CT4832]]

-In 0.48 i had game options with 44khz and no firelag at all
-hunkmegs=1024, sound megs=128 and zonemegs=256 didn't fix anything.
-In 0.49 with " seta s_khz "32" " firelag is completly gone.
-No low FPS during the game(it runs very very well).. It's not the graphic card.
-Makes the game unplayable :roll:

Author:  Myah [ Sat Sep 30, 2006 11:52 pm ]
Post subject: 

I'm also having big problems with this bug. I know it doesn't matter if you are in a full server or empty one. Though more people means it does it more. I also know that I have talked to some windows users with the exact same problem. It makes the game unplayable and all you do is get killed because your game is freezing or skipping. Also this has nothing to do with graphics because if the person is not even in view fireing it still happens but your own fireing doesn't cause it. Plus it's happens on all kinds of cards. Intel nvidia and ati. It really sucks as the new version looks so much nicer and I now down't have mouse lag like before if I cranck the res all the way up to 1920x1200 like 48 had.

My specs

Inpiron 9100 laptop.
3.2gig HT with 800mhz FSB
512mb ram running parrellel at 800mhz.
ATI 9700 with 128mb ram.
2.6.18 kernel
latest ati driver.
Myah OS. Slackare based.

But again this also happens in windows.

Just a thought is there a manuall way to set the sound at a lower setting if that is tied into the problem.

Author:  XenoKiLLer [ Sun Oct 01, 2006 12:27 am ]
Post subject: 

Thats serverlag + firelag bug + the new larger textures + HDR effects. You need more ram. 2x256Mb ram isnt gonna cut it even when running at dual channel mode. 2x512Mb however makes a difference when comparing to 1x1000Mb.

Author:  Myah [ Sun Oct 01, 2006 12:37 am ]
Post subject: 

I wish no other person would say anything about video settings or systems. Because this is absolutly not caused but any of that. The game runs smooth as butter I can set everything up and the res up as high as I like and my video card and computer can handle it all just fine. It has nothing to do with the actual gun firing becuae I can shoot my own gun all I want and nothing happens. It's also not server lag because I know what that looks like and it doesn't matter if I'm in a server where my ping is 20 and someone else is there and it's also 20 and it's only us.

Please if you don't have this problem don't give bad advise like turn your graphics down. We are not stupid here we would have already tried that before joining this forum. And it's not because of the textures and all that. Again I can crank everything up as high as I like. 1920x1200 is preatty high. But I play at 1024x768 just to be safe. It only happes when some one else fires a gun. You don't have to see the gun and they don't have to be shooting at you or anything. I think it might have something to do with the sound maybe. I'm not sure as I always played 0.48 at 22khz

I have tried the seta s_khz "32" and "22" then snd_restart and s_info and no matter what it says 44khz but the game option says it's custom. And it also has no affect on this bug. So who ever posted above that it fixed it please tell us more becase it didn't do shit for me.

Author:  XenoKiLLer [ Sun Oct 01, 2006 12:44 am ]
Post subject: 

We try to help you and you explode in the forums. I am trying to tell you the cause of lag you are getting is either server lag, system lag (lack of ram - loading on and off from the HDD virtual memory), or the firelag bug. it is either one those three. It isnt TCE nor ET becuase the rest of us can play without any hitches. It is possible that you may have some background applications running at the same time. Try not to download anything or run antivirus scans at the same time as playing. As much as possible limit communication software to one or two (Xfire or TS or Ventrilo etc., but not all).

Author:  Myah [ Sun Oct 01, 2006 1:06 am ]
Post subject: 

yeah I thank you for trying but your not understanding this bug at all. And your help your trying to give we are way past. Everything you mentioned has nothing to do with it. I do have a degree in hardware and software so I do get the basics. But thanks for trying.

Anyway for the rest of you that have this problem I think it is infact the sound like mentioned above. Thanks to Catalyc on the IRC he told me how to get around it and it seemed to work but only tied for about 5minutes but had no problems. I had to add the s_khz into the startup. He told me to try 32khz but the sound was strange and I still had the problem so I tried 22 and was able to play very smooth again and get some kills in. I'm going to play some more and see if it's good to go but this seems to be the problem. So try setting your startup script like this. And let us all know if it fixes your problems so we will know what works and what doesn't.

et +set fs_game tcetest +set com_hunkmegs 256 +set s_khz 22

Author:  XenoKiLLer [ Sun Oct 01, 2006 1:11 am ]
Post subject: 

Very well.. You do know that you posted a sound related issue in a thread regarding the firelag bug. Anyway that will be added to stickies soon.

Author:  Myah [ Sun Oct 01, 2006 1:44 am ]
Post subject: 

And you do know that it's what's causeing the firebug.
I have just talked to others that can now play be doing the exact same thing. They are getting the info from the IRC.

Author:  aidanr [ Sun Oct 01, 2006 2:30 am ]
Post subject: 

turning off the wallmark as suggested here fixed it for me

Author:  luminoso [ Sun Oct 01, 2006 2:49 am ]
Post subject: 

Also works here.. but...
If it is wallmark, why 32hkz sound also helps?! :?

Author:  it [ Sun Oct 01, 2006 2:56 am ]
Post subject: 

luminoso wrote:
Also works here.. but...
If it is wallmark, why 32hkz sound also helps?! :?

could be becuase the sound of gunfire also causes lag. I know it makes my ping increase by a little when I hear gunfire.

Author:  Myah [ Sun Oct 01, 2006 7:13 am ]
Post subject: 

Yeah it's a problem with linux and being forced to use 44khz it needs to be 22. Some people are tring 32 not sure why but it makes the sound bad and it still happends. But 22 fixes it. Not sure how walmark causes any trouble this is a sound issue. But there may be 2 different bugs.

Page 1 of 3 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group