All times are UTC




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: FPS drop (manual fix)
PostPosted: Fri Jan 22, 2010 6:01 pm 
Offline
Master
Master
User avatar

Joined: Thu Jul 13, 2006 10:19 am
Posts: 266
Location: Louisiana, USA
I've been having an issue with FPS dropping by 20+ frames, but it is very quick, and almost has no effect on my gameplay. But at really intense moments it causes momentary gameplay freeze (like net lag). It's more noticeable on high ping servers.

I have to Set ET.exe to CPU core 0, and run Xfire on CPU core 1. Same Dual Core problem as before.

If it wasn't for the quick drops, I wouldn't lag at all. :/

Anyone know if you can script WinXP to set Core Affinity on game startup?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 22, 2010 8:10 pm 
Offline
Master
Master

Joined: Sat Sep 02, 2006 4:03 pm
Posts: 398
Location: Croatia/Germany
i've been using this tool when i was on XP
thg task assign
there are 1 or 2 other tools but they never worked for me...
/edit: just tested, works on win7 too

_________________
=MaveXII=|WL Admin |IRC:#mave-clan
Image
*Clan Movie #2*|xfire: snakes3k


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 23, 2010 6:35 am 
Offline
Master
Master
User avatar

Joined: Thu Jul 13, 2006 10:19 am
Posts: 266
Location: Louisiana, USA
Thanks! Will test next time I play.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 23, 2010 5:13 pm 
Offline
Sharp Shooter
Sharp Shooter

Joined: Fri Jun 19, 2009 12:45 am
Posts: 38
i had this exact same problem with my old laptop, it would be fine for first few rounds then my fps is like 40 and drops to 5-10 then right back up, i couldn't find any fix but i think it has something to do with isp


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 23, 2010 6:56 pm 
Offline
Expert
Expert
User avatar

Joined: Thu Jul 09, 2009 8:28 pm
Posts: 204
Location: Canada
Spik3 wrote:
i had this exact same problem with my old laptop, it would be fine for first few rounds then my fps is like 40 and drops to 5-10 then right back up, i couldn't find any fix but i think it has something to do with isp

Your ISP doesn't control your fps, only your computer can change your fps.

_________________
Image
"Statistics is the study of how Greek letters can over-complicate graphs."


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 23, 2010 10:34 pm 
Offline
Master
Master
User avatar

Joined: Thu Jul 13, 2006 10:19 am
Posts: 266
Location: Louisiana, USA
If I had video capture I'd post a vid. You can barely tell it drops, but it's consistant, every 2-4 seconds, it will drop to 47, then back to my maxfps (60). Only hurts me in those all important corner turning shots.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 30, 2010 1:07 pm 
Offline
Master
Master
User avatar

Joined: Tue Jun 16, 2009 5:36 pm
Posts: 477
I wonder if its not PunkBuster scans.
TC:E on itself is not really a masterpiece of performence optimisation but PB is going to kill the smoothness.

We cant forget that after some time, windows got tons of updates and the system is not as fast as a fresh install too.

Two issues u wont experience with linux for exemple.

_________________
Image
xFire : wootheyetti


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 30, 2010 2:00 pm 
Offline
Rock Me, Amadeus!
Rock Me, Amadeus!

Joined: Thu Jun 11, 2009 10:38 am
Posts: 172
Location: Austria
]Wo0[ wrote:
Two issues u wont experience with linux for exemple.


yeah on linux you use graphics acceleration whenever there is a kernelupdate ;)

_________________
"Fog is neither water nor air, it's something between." Merlin


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 30, 2010 2:01 pm 
Offline
Master
Master
User avatar

Joined: Wed Aug 19, 2009 12:36 am
Posts: 433
Location: tri(p) city
&

-wifi signal quality (ask someone to check if your wifi channel does not interfere with other local wifi networks and what is the signal quality) or/maybe damaged cable so check plugs and/or ask your isp to check signal quality of your connection
-disk fragmentation
-video card tweeks
-background antivir quick scans
-any software update checks
-any tasks/apps running in background

ive heard about multicore problems with et but i have multicore and never experienced such problems.

Alpha Red wrote:
Your ISP doesn't control your fps, only your computer can change your fps.

connection interrupt also known as lag and warp might look as a fps drop

good luck =)


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 30, 2010 10:55 pm 
Offline
Master
Master
User avatar

Joined: Thu Jul 13, 2006 10:19 am
Posts: 266
Location: Louisiana, USA
Trust me, I'm no computer newb. I custom built my machine. I shouldn't be lagging (and I don't 99% of the time)

AMD Athlon 7750 Kuma OC'd @ 3.06ghz (dual)
2GB Mushkin DDR2 @ 850mhz
ASUS mobo w/ 1TB SATA HDD
nVidia GF 8800gts 320mb

I think Wo0 is correct, PB seems to be an issue. Especially when running XFire.

Its been on and off lately. Using that Task Assign Snake posted. Doesn't seem to completely get rid of the stutters. I wish I could assign PB.exe to a specific Core...


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jan 31, 2010 11:05 am 
Offline
Marksman
Marksman
User avatar

Joined: Sat Jan 19, 2008 7:50 am
Posts: 23
Location: Germany
If you have WLAN its often the Vista Index that causes the Issue.
The index searches every (5?) seconds for new WLAN Stations and that causes extreme LAG and FPS drop.

Try to search on google about that there should be plenty threads

_________________
Xfire user
Image


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jan 31, 2010 8:00 pm 
Offline
Master
Master
User avatar

Joined: Thu Jul 13, 2006 10:19 am
Posts: 266
Location: Louisiana, USA
Nope, Desktop with wired connection. Definitely PB.

Something else I've noticed. When setting max fps to a higher number, when it drops fps, it goes to the "magic numbers". Like.. 90-76... 62-47.. Weird!


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 02, 2010 1:41 pm 
Offline
Master
Master

Joined: Sat Sep 02, 2006 4:03 pm
Posts: 398
Location: Croatia/Germany
pb is definitely causing lil lags, but i wouldnt say that ur fps drops are coming from pb (only)
i have lil fps "stutters" too and tried non pb servers/hosting a non-pb game without success... its hard to get rid of it :/

76 is the only "magic number" u mentioned^^ this is just imagination, theres no reason why it should jump to 43/76 :P

_________________
=MaveXII=|WL Admin |IRC:#mave-clan
Image
*Clan Movie #2*|xfire: snakes3k


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 02, 2010 2:05 pm 
Offline
Master
Master
User avatar

Joined: Wed Aug 19, 2009 12:36 am
Posts: 433
Location: tri(p) city
well ive noticed some 'hickups' ingame as seen at ss lagometer
those apear when i am freshly connected to any map or/on any server
Image

but they disapear after ~minute (to be clear: was saving xfire ss so thats why 2 mins passed)
Image

those 'lil green spikies' like to apear from nowhere and disapear into the void

and belive me ive got whole chapter in my cfg to optimize pb =)


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 02, 2010 2:32 pm 
Offline
Master
Master

Joined: Sat Sep 02, 2006 4:03 pm
Posts: 398
Location: Croatia/Germany
oh come on, its nearly impossible to keep the connection perfect on a server the whole time, u will see these small connection spikes on all servers all the time (i even remember having that on a lan game with friends), the spikes go even higher at round start but thats normal, the serverconnection(quality) changes with the number of players connected, pb, other mods like etadmin,.(pb_ss,...).
your ss show perfectly normal server behaviour.
if its a pure fps lag, it should show in the lagometer anyway..
tce is not a perfect game, and it'll never be. we'll just have to live with the flaws it has^^

_________________
=MaveXII=|WL Admin |IRC:#mave-clan
Image
*Clan Movie #2*|xfire: snakes3k


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Style created by © Matti, gry komputerowe, reklama sem reklama seo

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group