TrueCombat
http://www.truecombatelite.com/forums/

Empty map list
http://www.truecombatelite.com/forums/viewtopic.php?f=21&t=2106
Page 1 of 1

Author:  talis [ Mon May 31, 2010 7:16 am ]
Post subject:  Empty map list

Hi.
I've downloaded TCE about 4 days ago. The version that had been published by that time does not show me any maps in "host game". I tried different variations of patched/unpatched TCE and ET but that did not work. Maybe this is some system-related bug, I don't know. I have Ubuntu 10.04. Please tell me if you need some other information here.
Thank you.

Author:  SnaKeS3K [ Mon May 31, 2010 12:33 pm ]
Post subject: 

sometimes the custom packs can cause this (if there are too many for example) try to move some of them out of the tcetest folder (just sort the files by date modified and you will see the zzz_.. yy_.. obj_... files).
if that doesnt work then you can load the map you want by opening the console (^ or ~) and typing /map obj_northport or any other mapname (/devmap works too, this will load the map in developer mode with cheats enabled)

Author:  talis [ Mon May 31, 2010 1:01 pm ]
Post subject: 

Thank you for your reply.

The strange thing is that TCE does not work out-of-the-box, with no content downloaded yet. Will the /map command allow people to connect me from LAN or Internet? Is there an option that switches the network class to use (like sv_lan in HL1/Source Engine)?

ADDED:
I tried /map, but it says I have invalid or modified paks, so it can't run official server. How do I run an unofficial server? I don't want to move all files I've downloaded so far from dir to dir.

Author:  SnaKeS3K [ Mon May 31, 2010 4:28 pm ]
Post subject: 

to run a server with modified paks, use /sv_official 0 or go to the host game menu and tick->untick the "official server" feature, that should work as well.

Quote:
Will the /map command allow people to connect me from LAN or Internet? Is there an option that switches the network class to use (like sv_lan in HL1/Source Engine)?

you can do /dedicated 2 , this will run the server as a dediccated one allowing people to connect over the internet. it'll open up a console where u can then type in /map obj_...
/dedicated 1 - is a dedicated lan server
/dedicated 0 - is basically play and serve
if u wanna join ur dedicated server, you can simply run a 2nd tce process

Author:  talis [ Tue Jun 01, 2010 1:41 pm ]
Post subject: 

Ok, I see it. Thank you very much!

P.S. And this is a king of bug you really should investigate!

Author:  merlin1991 [ Wed Jun 02, 2010 8:51 pm ]
Post subject: 

uhm

I dunno what the actual bug is, but when you have an empty maplist in the host game menu it's often caused by an invalid gametype (however that can happen) but you can fix it by cycling through the gametypes (aka clicking it at least once :D)

edit:

also the "official server" aka no custom pk3s in tcetest or etmain checkbox isn't working correctly

if it's unchecked when you go into host game you have to check and uncheck it to have the desired effect :lol:

Author:  talis [ Thu Jun 03, 2010 8:51 am ]
Post subject: 

I tried launching et and changing game type to tcetest - still not working. Today I will try this distribution at my friend's machine and report back. Something is telling me that this can be a system-related bug.

Author:  talis [ Sun Jun 06, 2010 2:37 pm ]
Post subject: 

My friend has certain problems with his hardware right now, so I won't be able to test TCE on his machine for a while. But as soon as we solve those problems I will post information on the subject. It should be a matter of a week or so.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/