All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: VM_Create on UI failed Ubuntu 9.10
PostPosted: Sat Mar 27, 2010 3:13 am 
Offline
Marksman
Marksman
User avatar

Joined: Tue Mar 23, 2010 8:14 am
Posts: 11
Location: US
I finally got this game installed, but now i have a new problem:

The error:
Code:
Sound memory manager started
Sys_LoadDll(/home/miotatsu/.etwolf/tcetest/ui.mp.i386.so)...
Sys_LoadDll(/home/miotatsu/.etwolf/tcetest/ui.mp.i386.so) failed:
"/home/miotatsu/.etwolf/tcetest/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/usr/share/games/enemy-territory/tcetest/ui.mp.i386.so)...
Sys_LoadDll(/usr/share/games/enemy-territory/tcetest/ui.mp.i386.so) failed:
"libstdc++.so.5: cannot open shared object file: No such file or directory"
Sys_LoadDll(ui) failed dlopen() completely!
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: VM_Create on UI failed


The full log:
Code:
ET 2.60b linux-i386 May  8 2006
----- FS_Startup -----
Current search path:
/home/miotatsu/.etwolf/tcetest
/usr/share/games/enemy-territory/tcetest/pak4.pk3 (113 files)
/usr/share/games/enemy-territory/tcetest/pak3.pk3 (411 files)
/usr/share/games/enemy-territory/tcetest/pak2.pk3 (2066 files)
/usr/share/games/enemy-territory/tcetest/pak1.pk3 (1869 files)
/usr/share/games/enemy-territory/tcetest/pak0.pk3 (728 files)
/usr/share/games/enemy-territory/tcetest/mp_bin.pk3 (6 files)
/usr/share/games/enemy-territory/tcetest
/home/miotatsu/.etwolf/etmain
/usr/share/games/enemy-territory/etmain/pak2.pk3 (22 files)
/usr/share/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/share/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/share/games/enemy-territory/etmain/mp_bin.pk3 (6 files)
/usr/share/games/enemy-territory/etmain

----------------------
8956 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing profiles/miotatsu/etconfig.cfg
execing autoexec.cfg
com_zoneMegs will be changed upon restarting.
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: ATI Radeon HD 3200 Graphics
Initializing OpenGL extensions
...using GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...GL_NV_fog_distance not found
... GL_EXT_texture_filter_anisotropic not found
Initializing GLX extensions
...using GLX_SGI_swap_control
...using GLX_SGI_video_sync
XF86 Gamma extension initialized

GL_VENDOR: ATI Technologies Inc.
GL_RENDERER: ATI Radeon HD 3200 Graphics
GL_VERSION: 2.1.9016
GL_EXTENSIONS: GL_ARB_multitexture GL_EXT_texture_env_add  GL_EXT_compiled_vertex_array GL_S3_s3tc
GLX_EXTENSIONS: GLX_ARB_create_context GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_MESA_swap_control GLX_NV_swap_group GLX_OML_swap_method GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_swap_barrier GLX_SGIX_swap_group GLX_SGIX_visual_select_group
GL_MAX_TEXTURE_SIZE: 8192
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
------------------------------------
----- Sound Info -----
sound system is muted
    1 stereo
32768 samples
   16 samplebits
    1 submission_chunk
44100 speed
0x0xab899000 dma buffer
No background file.
----------------------
Sound memory manager started
Sys_LoadDll(/home/miotatsu/.etwolf/tcetest/ui.mp.i386.so)...
Sys_LoadDll(/home/miotatsu/.etwolf/tcetest/ui.mp.i386.so) failed:
"/home/miotatsu/.etwolf/tcetest/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/usr/share/games/enemy-territory/tcetest/ui.mp.i386.so)...
Sys_LoadDll(/usr/share/games/enemy-territory/tcetest/ui.mp.i386.so) failed:
"libstdc++.so.5: cannot open shared object file: No such file or directory"
Sys_LoadDll(ui) failed dlopen() completely!
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: VM_Create on UI failed
miotatsu@laptop:~/Desktop$

_________________
:O


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 27, 2010 9:34 am 
Offline
Sharp Shooter
Sharp Shooter
User avatar

Joined: Sat Jun 13, 2009 9:50 am
Posts: 78
Location: Poland
That's the reason of the problem:
Code:
libstdc++.so.5: cannot open shared object file: No such file or directory

Solution:
Code:
apt-get install libstdc++5

But there is probably no libstdc++5 in Ubuntu 9.10. All you need to do in this situation is install libstdc++6 and make a symbolic link to this library:
Code:
apt-get install libstdc++6
ln -s /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.5

I don't have to say, that you have to run this commands from root user. Hope this will help :-)

_________________
Image

Image


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 27, 2010 10:09 pm 
Offline
Marksman
Marksman
User avatar

Joined: Tue Mar 23, 2010 8:14 am
Posts: 11
Location: US
ah thank you!, i had libstdc++6 already, i just needed to link it, it works now (well i haven't tried playing yet, but it launches fine) :)

edit: also i just installed XQF, but I don't know how to set it up to see the TC:E servers, I could use some help, i looked through the various menus and did not see anything of interest, as of now i have not looked at the documentation for XQF yet however.

_________________
:O


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Style created by © Matti, gry komputerowe, reklama sem reklama seo

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group